Shutter

From mxlinuxusers.de
Jump to navigation Jump to search
grafische Oberfläche von shutter

Shutter ist ein Screenshot-Programm mit vielen Funktionen. Damit können Screenshots vom gesamten Bildschirm, eines einzelnen Fensters oder eines frei wählbaren rechteckigen Bereiches gemacht werden. Sogar der Screenshot einer entfernten Webseite ist damit möglich. Diese Screenshots können anschliessend mit dem eingebauten Grafik-Editor bearbeitet werden, indem man Texte, Figuren (Rechtecke, Kreise u.ä.), Linien und Effekte hinzufügt. Die fertigen Screenshots können in beliebigen Grafikformaten abgespeichert werden (auch pdf, ps oder svg) und zu Image-Hostern oder FTP-Servern hochgeladen werden.

Screenshot aller Arbeitsflächen

Die Bedienung von Shutter ist sowohl über eine grafische Oberfläche (s. Bild) als auch direkt über die Kommandozeile möglich.

shutter kann auch Screenshots von allen Arbeitsflächen gleichzeitig machen. Dafür ist wohl keine Option vorhanden, sondern es wird über die grafische Oberfläche ausgewählt: Menupunkt "Schreibtisch" -> "alle Arbeitsflächen aufnehmen".

Optionen[edit | edit source]

ruft man shutter über die Kommandozeile auf, so können diese Optionen mitgegeben werden. Dabei gibt es Optionen für die Art des Screenshots, für die Behandlung des Screenshots und Optionen die shutter direkt betreffen.

Screenshot Optionen[edit | edit source]

  • -s [=X,Y,BREITE,HÖHE]
Auswahl eines Bereiches mit der Maus. Werden die optionalen Koordinaten X, Y, BREITE, HÖHE angegeben (ohne die eckigen Klammern), so wirde der damit bezeichnete Bereich ausgewählt. Beispiel: shutter -s=100,100,300,300
  • -f
Screenshot vom ganzen Bildschirm
  • --w, --window=[NAME_MUSTER]
Auswahl eines einzelnen Fensters. Bei Angabe des optionalen NAME_MUSTER (Wildcartds möglich) wird das Fenster aufgenommen, dessen Name auf dieses Muster passt. Beispiel: shutter --window=.*firefox.* -> Aufnahme vom Firefox-Browser
  • -a
Screenshot vom aktiven Fenster
  • --web=[URL]
Screenshot einer Webpage. Die Angabe der URL ist optional. Beispiel: shutter --web=http://shutter-project.org/. Wird keine URL angegeben, so wird sie im sich öffnenden Dialog-Fenster eingeben.

Einstellungsoptionen[edit | edit source]

  • -p, --profile=NAME
lädt shutter mit dem Profil NAME. Beispiel: shutter -p=mein_profil
  • -o, --output=FILENAME
Filename für den Screenshot angeben. Dabei sind auch diese Wildcards möglich:
%Y = Jahr
%m = Monat
%d = Tag
%T = Uhrzeit
$w = Breite des Screenshots
$h = Höhe des Screenshots
$profile = Name des aktuellen Profils
$R = zufälliger Name (z.B. $RRRR = ag4r)
%NN = Zähler
Der Dateiname mit Datums-/Zeitangaben wird von strftime interpretiert.
  • -d, --delay=SEKUNDEN
Verzögerung bis zum Screenshot in Sekunden
  • -c
Cursor wird mit aufgenommen
  • -C
Screenshot ohne Cursor

Optionen für shutter[edit | edit source]

  • -h
Anzeige der Hilfefunktion
  • -v
Ausgabe der Version von shutter
  • --debug
gibt auf stdout eine Reihe von Debug-Infos aus, die für die Fehlersuche nützlich sein können
  • --clear_cache
leert beim Start den Cache von shutter (z.B. geladene Plugins)
  • --min_at_startup
startet shutter minimiert als Icon im Tray
  • --disable_systray
startet shutter ohne Icon im Tray
  • -e
beendet shutter sofort nach dem ersten Screenshot. Nützlich für die Anwendung in Skripten

Profile[edit | edit source]

Da shutter sehr viele Einstellmöglichkeiten hat ist es möglich, diese in sogenannten Profilen zu speichern. So kann man z.B. ein Profil anlegen, das standardmäßig den Screenshot nach Imgur hochlädt, ein anderes, das die Farbtiefe des Screenshots automatisch auf 4bit(16 Farben) reduziert und als Dateityp nicht png sondern jpg benutzt, usw. Der Phantasie sind keine Grenzen gesetzt.

shutter Profilauswahl

Diese Profile erreicht man über die Menupunkte "bearbeiten" -> "Einstellungen". Dort in den zahlreichen Tabs und Untertabs alles wie gewünscht einstellen und zum Schluß unter "Shutter-Einstellungen" -> Tab "Allgemein" -> "Profil" mit einem passenden Namen abspeichern. Aufgerufen werden diese Profile dann entweder über die Kommandozeile mit der Option -p

shutter -p Profilname

oder in der Shutter-Oberfläche (GUI) über den Menupunkt "Bearbeiten" -> "Profilauswahl"

Gespeichert werden die Profile unter ihrem Namen im Homevezeichnis des Users als xml-Dateien im Ordner ~/.shutter/profiles/ Sie könnten also durchaus auch in einem Editor betrachtet oder gar bearbeitet werden. Vorzuziehen ist jedoch der oben beschriebene Weg über die shutter-Einstellungen.

Erweiterungen[edit | edit source]

shutter enthält eine umfangreiche Sammlung von Erweiterungen (Plugins), mit denen der Screenshot nachträglich noch bearbeitet und mit verschiedenen Effekten versehen werden kann:

  • automatisch zuschneiden
  • erhobener Rahmen
  • Graustufen
  • Größe ändern
  • Invertieren
  • Kanten abrunden
  • Polaroid
  • Schlagschatten
  • Sepia
  • Tonnenförmige Verzerrung
  • Versatz
  • versunkener Rahmen
  • Wasserzeichen
  • zerfetztes Papier

Grafik-Editor[edit | edit source]

Grafik-Editor von shutter mit Beispielbearbeitungen

shutter bietet über das Menu "Bildschirmfoto" -> "öffnen mit" die Möglichkeit, den Screenshot an jedes installierte Grafikprogramm zu übergeben und damit zu bearbeiten.

Außerdem hat shutter aber auch einen eingebauten Grafik-Editor (Shutter Drawing Tool), mit dem der Screenshot direkt bearbeitet werden kann. Dazu ist es notwendig, das Paket libgoo-canvas-perl von Hand nachzuinstallieren, da dies zumindest bei MX-18 nicht automatisch passiert. Den Grafik-Editor erreicht man entweder durch einen Rechtsklick auf den Screenshot, Menupunkt "Bearbeiten", oder über die zweite obere Menuleiste -> Auswahl "Bearbeiten".

ACHTUNG: Unglücklicherweise gibt es zwei Menupunkte "Bearbeiten", einen in der ganz oberen Reihe, rechts neben "Datei", dieser ist es nicht, sondern der Menupunkt eine Reihe tiefer, ziemlich weit rechts, zwischen "Web" und "Exportieren".

linke Menuleiste des Grafik-Editors

Im sich öffnenden Fenster "Shutter Drawing Tool" gibt es in der linken vertikalen Leiste folgende Bearbeitungsmöglichkeiten (von oben nach unten):

  • Objekt zum Verschieben oder Skalieren auswählen
  • Freihandlinie zeichnen
  • Textmarker
  • gerade Linie zeichnen
  • Pfeil zeichnen
  • Rechteck zeichnen
  • Ellipse zeichnen
  • Text hinzufügen
  • ausgewählte Bereiche zensieren (mit Muster überschreiben)
  • ausgewählte Bereiche verpixeln
  • automatische Nummerierung hinzufügen
  • Bild zuschneiden
untere Menuleiste des Grafik-Editors

für all diese Aktionen gibt es am unteren Bildschirmrand noch die Möglichkeit, Füllfarbe, Linienfarbe und -stärke sowie Schriftart und -grösse einzustellen.

untere Menuleiste: Menupunkt "Bild einfügen"

Der Menupunkt "Bild einfügen" in dieser unteren Menuleiste bietet außerdem die Möglichkeit, Icons und Bilder aus einer sehr großen Auswahl in den Screenshot einzufügen.